18RG running pretty well!

The motor would run well when cold, but as soon as it warmed up, it would run absolutely awful. It would misfire constantly and stall at every stop. Once it stalled it would be impossible to restart. I deduced it was ignition related. I hate distributors. I had converted this one to electronic ignition with parts from a 22R electronic distributor, so I knew there were no problems with the points (because there were none). The coil was new (Autozone special) so that wasn’t the problem. I changed all the wires with a known good pair and it didn’t change it. I still don’t know exactly what was causing it.

I bought an 18RG pulley with a 36-1 tooth wheel welded to it along with a VR sensor and sensor mount from my friend Stu many years ago. I ended up using the sensor on my 77 Corolla EFI conversion, and I lost the 18RG mount. 🙁

I just crushed the Corolla the EFI was in so I had the system sitting on the shelf. I decided to install the Megasquirt quickly just to control the ignition. When I convert the entire motor to EFI I’m going to use a Megasquirt MS3X and will have sequential injection and ignition. That will be different post though, and likely a winter project (because I’m DEFINITELY not driving it in winter any more!)

After I had it installed, the engine fire up immediately on the first crank! After cleaning up the install a little, (I put the Megasquirt at the passenger floor after pushing the wires through the grommet hole.

I pulled the factory distributor and plugged the 18RG dizzy hole.

photo 20150822_105056_zpszijuzar7.jpg

photo 20150822_105105_zpsczrosii9.jpg

I had to build a new VR sensor mount. Luckily it was very simple. Basically a bent piece with holes in it. 20 minutes and I had it ready.

photo 20150822_110044_zps05mcdui8.jpg

photo 20150822_110141_zps15rhphdc.jpg

photo 20150822_110217_zps1uuf1tul.jpg

I need to make this gap a bit smaller, but it works for now. (The RPM signal will likely start to break up at higher RPM’s with this big of a gap)

photo 20150822_110635_zpsbrzxd2gk.jpg

It ran when I had all this just sitting up on top. But I couldn’t drive it like that.

photo 20150822_111749_zpsrh7fx9jn.jpg

I pulled off the fender to route the wires inside. You can see some of my other “amazing” wiring work from 5 years ago when I did a wire tuck. It all works.

photo 20150822_112746_zpswei5k1yt.jpg

photo 20150822_115045_zpsoghxhxlt.jpg

I modified these Megasquirt wiring diagrams to fit what I did with my harness.

photo 20150822_110826_zpsop6cwiod.jpg

photo 20150822_110833_zpsrinxx1sj.jpg

I drove it 10 miles today in a single drive and it didn’t stall once! So I *think* it’s ready to go to the car show tomorrow. 🙂

I could only find one of my fender mirrors. The other has just disappeared. My son probably hid it somewhere. I’ll show some more pictures later today.

Anybody need an electronic 18RG distributor?

Leave a Reply

Your email address will not be published. Required fields are marked *